Error: Unable to connect to the service provider


Challenge

Veeam console reports one of the following errors:

Certificate validation failed. Unable to connect to the service provider.
Certificate validation failed. Authentication failed because the remote party has closed the transport stream.

Solution

Multiple solutions:

  • Run Windows updates on the machine where Veeam Backup & Replication or Veeam Agent is installed. Further details can be found here
  • Open the necessary ports required
  • Allow the ReVirt service through the adaptive security

Cause

There can be multiple reason to the error:

 

  • An update to the .NET Framework introduces a security check and do not allow to establish a secure connection to ReVirt
  • A connection to the ReVirt service cannot be established on the port TCP 6180.
  • Firewall that have adaptive security features like “deep packet inspection”, “packet inspection” or SSL/TLS inspection. This introduces a man-in-the-middel scenario and can cause issues to the exchange of the certificates

 


 

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